audiohobby.ru audiohobby.ru

Обсуждение вопросов по запуску и отладке ЦАП AH-D6

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: MCA-64
при подаче питания на входных нечётных пинах микроконтроллёра (ATmega88) 1,65в, а не 3,3в

1) — это не нормально, разбирайтесь. Верификацию прошивка проходит после заливки? Что по питанию? Что на пине резета МК, пин 29?

Цитата: MCA-64

 Подключаю кабеля USB от ПК ко входу ЦАП (звук на ПК отключается), дальше на выходе усилителя тишина, если кабель USB отсоеденить от входа ЦАП, на ПК звук появляется. 

2) USB устройство выбирается устройством вывода по умолчанию,  вывод звука идет на аманерку, удивляться нечему.

Редактировалось 2 раза, последний: 22:45
Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: MCA-64
На конденсаторах С12  140мВ,    С13  300мВ

— значит смотрите питание клоков, на одном из них должно быть 3.3в (в зависимости от замыкании пина 1(control) на землю)

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: admin
С21,   С47  +5В.

С21, С47 +5В. — откуда там 5в, должно быть 3.3в 

ko888
Был
Пользователи
Нет тем
35 сообщений
Рейтинг: 4
Репутация: 0
На сайте 2 года

Добрый день!

Прикупил генераторы SiTime на алишке вот здесь https://aliexpress.ru/item/4000152209411.html?spm=...

Есть подозрения. 

Пришло в 2-х подписанных пакетиках. Маркировка обоих чипов на 22,5297 и 24,576 - одинаковая AOHRM размер 5х7 мм.

Что мне прислали? Маркировка никак не бьется

rucrim
Был сегодня
Знатоки
Нет тем
50 сообщений
Рейтинг: 46
Репутация: 0
На сайте 4 года
Цитата: ko888

Добрый день!

Прикупил генераторы SiTime на алишке вот здесь https://aliexpress.ru/item/4000152209411.html?spm=...

Есть подозрения. 

Пришло в 2-х подписанных пакетиках. Маркировка обоих чипов на 22,5297 и 24,576 - одинаковая AOHRM размер 5х7 мм.

Что мне прислали? Маркировка никак не бьется

Они программируемые по этому одинаковые.

dim
Был
Новички
Нет тем
7 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

Здравствуйте! Вопрос так ли нужны u1 и u2? Можно без них обойтись.

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: dim
u1 и u2? Можно без них обойтись.

нельзя

dim
Был
Новички
Нет тем
7 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

Всем Здравствуйте! Есть желание купить у diyinhk NZ2520SDA на 22,5792 и 24,576 МГц, но доставка 35 долларов.Может будут желающие присоединится к покупке? Нужно 5 чел из Москвы.

Редактировалось 1 раз, последний: 18:14
emon
Был
Пользователи
2 темы
27 сообщений
Рейтинг: 11
Репутация: 0
На сайте 2 года
Цитата: dim

Всем Здравствуйте! Есть желание купить у diyinhk NZ2520SDA на 22,5792 и 24,576 МГц, но доставка 35 долларов.Может будут желающие присоединится к покупке? Нужно 5 чел.

брал вот эти ничем не хуже тех что с diyinhk

не верь жене и тормозам
dim
Был
Новички
Нет тем
7 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

Удивительно дешево! Неужто так может быть?

dim
Был
Новички
Нет тем
7 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

В чипе и дипе есть возможность заказать C3391 от Crystek-как они по сравнению с NDK?

Редактировалось 1 раз, последний: 12:04
ko888
Был
Пользователи
Нет тем
35 сообщений
Рейтинг: 4
Репутация: 0
На сайте 2 года
Цитата: lopuh

Вот мои городушки. Корпус с Али 2205, получилось достаточно плотно. Красоты монтажа внутри корпуса опять нет(((

Подскажите как или где сделали вырез под LCD?

LampCos
Был
Пользователи
Нет тем
6 сообщений
Рейтинг: 2
Репутация: 0
На сайте 2 года

Приветствую всех. Требуется помощь.

МК — Atmega88-20U (покупался в Терраэлектронике, по сути в Электронщике)

В программе выбираю Atmega88, устанавливаю фьюзы, как указано, перемычка для медленной скорости стоит. Прошиваюсь с питанием от самого программатора. Все прошивается, после прошивки выдает, что верификация вроде все ок, однако в строке самой программы пишет что 0 байтов верифицировано.

Это и означает, что верификация не пройдена?

Проверяю наличие «1» на сигнальных пинах — по 1,5В, где-то по 0,9В. Напряжение на пине сброса (29) — 3,3. Питание — 3,3.

Спасибо заранее

после прошивки отключил-включил программатор. Нажал во вкладке Program кнопку верификации в разделе Flash, получил в окне программы вот такое сообщение

Cформированная командная строка:

avrdude.exe -p m88 -c usbasp -P usb -U flash:v:«H:\Домашний звук\AVRDUde\AH-D6-firmware-v2.1-atmega88-1Mhz\AH-D6-mk3-ak4493-firmware-v2.1-atmega88-1Mhz.hex»:a

avrdude.exe: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.01s

avrdude.exe: Device signature = 0x1e930a (probably m88)

avrdude.exe: verifying flash memory against H:\Домашний звук\AVRDUde\AH-D6-firmware-v2.1-atmega88-1Mhz\AH-D6-mk3-ak4493-firmware-v2.1-atmega88-1Mhz.hex:

avrdude.exe: load data flash data from input file H:\Домашний звук\AVRDUde\AH-D6-firmware-v2.1-atmega88-1Mhz\AH-D6-mk3-ak4493-firmware-v2.1-atmega88-1Mhz.hex:

avrdude.exe: input file H:\Домашний звук\AVRDUde\AH-D6-firmware-v2.1-atmega88-1Mhz\AH-D6-mk3-ak4493-firmware-v2.1-atmega88-1Mhz.hex auto detected as Intel Hex

avrdude.exe: input file H:\Домашний звук\AVRDUde\AH-D6-firmware-v2.1-atmega88-1Mhz\AH-D6-mk3-ak4493-firmware-v2.1-atmega88-1Mhz.hex contains 0 bytes

avrdude.exe: reading on-chip flash data:

Reading | ################################################## | 100% -0.00s

avrdude.exe: verifying ...

avrdude.exe: 0 bytes of flash verified

avrdude.exe: safemode: Fuses OK (E:F9, H:DF, L:62)

avrdude.exe done. Thank you.

То есть получается верификацию не проходит?

Редактировалось 1 раз, последний: 07:00
Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года

Можете фьюзы считать и выложить?

LampCos
Был
Пользователи
Нет тем
6 сообщений
Рейтинг: 2
Репутация: 0
На сайте 2 года

Всё получилось.

Обратил внимание на вот эту надпись

"0 bytes of flash verified"

Полез смотреть сколько весит файл прошивки, оказалось всего то 13 байт

Не могу сказать, как так получилось, но судя по дате создания, каким то образом при первой попытке прошиться, он подменился хз чем.

Скачал заново и вот такой результат

Перед этим стёр, прога выдала, что кристалл чист. Перешел во вкладку фьзов, нажал чтение, единственное что отличалось, так это значения в самых крайних ячейках «HEX», точнее в первых двух, но галочки совпали. Прошился. Начал промерять — на всех сигнальных пинах 3,3В. Проверил Реле — замкнул выводы, и примерно через полсекунды щелчок.

...

сейчас прочитал, что  во фьюзах в прошитой атмеги

все норм получилось.

Редактировалось 3 раза, последний: 06:27
lopuh
Был
Пользователи
Нет тем
4 сообщения
Рейтинг: 11
Репутация: 0
На сайте 3 года
Цитата: ko888
Цитата: lopuh

Вот мои городушки. Корпус с Али 2205, получилось достаточно плотно. Красоты монтажа внутри корпуса опять нет(((

Подскажите как или где сделали вырез под LCD?

Извините, только увидел вопрос… Чисто слесарка, высверлено по контуру, дальше напильник-надфиль.

Dafin314
Был сегодня
Новички
1 тема
3 сообщения
Рейтинг: 0
Репутация: 0
На сайте 4 месяца

Приветствую всех. Несколько дней как собрал AH-D6 из набора. Проблема следующая, немного ускоренное воспроизведение За четырех минутную композицию набегает 20 секунд разницы с реальным временем. Кварцы не перепутаны Y1-24.576, Y2-22.579 оригинальность гарантировать не могу. USB транспорт Чарльстон Энергетика подключен только i2s, 3 контакт Control закорочен на землю.

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: Dafin314
Control

Почему Control не подключен? 

Dafin314
Был сегодня
Новички
1 тема
3 сообщения
Рейтинг: 0
Репутация: 0
На сайте 4 месяца

Большое спасибо, я разобрался вроде. Шлейф подключал не правильно когда первый раз пробовал. Еще раз спасибо за ответы и еще большее за конструкцию. Она позволяет при невысоком уровне знаний, но внимательности и аккуратности собирать сложные устройства.

fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Всем привет! Наверное «окирпичел» свой AK4493! Первое включение сделал как и положено без резисторов перемычек. Напряжение на резисторах FR13 и FR14 было 5 Вольт. Запаял перемычки, включил, на FR13 — 5, 01 Вольт, а на FR14 — 7 Вольт !!!.. Быстро все выключил, стал разбираться и нашел не пропаянную ногу на U23. Все пропаял, теперь напряжение на FR13 — 5,01 Вольт, а на FR14 — 4,98 Вольт. Но самое страшное, падение напряжения на резисторе FR13 — 0 мВ, на на FR14 — 28 мВ (Сопротивление резисторов одинаковое). Такой разный ток может быть? Или это приговор? Остальные напряжения в норме, есть небольшая разница между С5/С50 — 11,01 Вольт и С15/С63 — 10,98 Вольт, но думаю это не критично! На звук пока не проверял, т. к. есть проблема с прошивкой контролера.

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: fedy
Такой разный ток может быть?

 скорее всего вышел из строя один канал чипа... 

Цитата: fedy
есть небольшая разница между С5/С50 — 11,01 Вольт и С15/С63 — 10,98 Вольт, но думаю это не критично!

да я бы сказал идеально, обычно разброс больше

Цитата: fedy
На звук пока не проверял, т. к. есть проблема с прошивкой контролера.

надо проверять и разбираться с прошивкой. Там же станет ясно на сколько пациент жив.

Редактировалось 1 раз, последний: 20:21
fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Доброй ночи! По поводу прошивки. Прошивал сразу два контроллера Atmega 88 — 20AU (на плате цап и на модуле индикации), в обоих случаях все прошивается и верифицируется! В модуле индикации не было 1 на выходе 29 (Reset) контроллера, проблема была в супервизоре, сейчас все работает. А на плате цап все хуже! После прошивки 

на выходе 29 (Reset) контроллера — 1, но на всех сигнальных пинах разъемов CONTROL / CONFIG — 0,9 — 1,5 Вольт. Смущает два момента: 1 — если очистить память контроллера и считать фьюзы, то получается 

2 — на какой частоте работает контроллер? Прошивал с перемычкой JP3 на программаторе. 

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: fedy
2 — на какой частоте работает контроллер?

на частоте 8МГц, опустите частоту до 1МГц, установив галку CKDIV8 (Fuse Low Byte). Шить после этого только с перемычкой JP3 на программаторе, а пока частота 8МГц, то МК прошивается как с перемычкой так и без перемычки.

Что касается High Byte

  • Галку BODLEVEL1 можно оставить, супервизор внешний, тогда вам будет не нужен. 
  • Сторожевой таймер WDTON выключить!, иначе микроконтроллер будет постоянно сбрасываться!
  • EESAVE не важно, тк EEPROM не используется. 

Судя по установленным фьюзам МК у вас явно из серии Б/У… ничего общего со значениями по умолчанию.

------------

И теперь основной вопрос откуда у вас при верификации набралось 4906 байт. Подскажите откуда взяли прошивку?

Для D6 все прошивки искать во вложениях к моей статье (https://audiohobby.ru/articles/vysokokachestvennyi-cap-ah-d6-versija-2-h.html), ну нет там ни одной прошивки такого объема. При верификации должно быть ~2000 для ak4490 и ~2300-2400 байт для ak4493!

И еще на всякий случай, кнопку «Чтение» в AVRDUDE_PROG не нажимать, иначе вы считаете содержимое атмеги в файл, который выбран, т.е. перезапишите / испортите его. А дальше можно сколько угодно шить атмегу ее старой прошивкой, результата, конечно, не будет. 

Редактировалось 1 раз, последний: 10:08
fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Доброй ночи! Предварительное спасибо за помощь. Стер файл прошивки, скачал его заново с сайта, поменял фьюзы и все получилось! Проверил, по рекомендации, на всех сигнальных пинах разъемов CONTROL / CONFIG — 3,3 Вольта, реле щелкает. Следующий шаг, подключил Amanero с платой адаптера. Amanero проверенная (в режиме master mode) на другом ЦАПе, 100 % рабочая. Перевел ее в slave mode (поставил только галочку в программе oem tool 117), включил foobar, все настроил, запустил трек, щелкнуло реле, но звука нет! Остановил трек и foobar завис, реле не щелкнуло обратно. И так каждый раз, причем реле включается в момент включения трека, а выключается только при отключении питания ЦАПа! Перевел Amanero в режим master mode, поставил перемычку на контакт 5 разъема CONFIG и массой. Foobar перестал зависать, треки включаются и выключаются, но реле по прежнему включается при первом треке и выключается только при отключении питания ЦАПа! Звука естественно нет, так гальваническая развязка у меня IL717 (Китайская). Думаю, что предыдущее насилование ЦАПа не может привести к такому.

Завтра буду думать с чего начинать поиски проблемы !

Редактировалось 1 раз, последний: 00:30
Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: fedy
Остановил трек и foobar завис, реле не щелкнуло обратно.

 Тут не угодишь,  народ комментах просил же, чтобы щелкало реле как можно меньше, так что щелкать обратно на PCM формате оно и не должно, здесь отрабатывает софтовый mute. 

Цитата: fedy
Следующий шаг, подключил Amanero с платой адаптера. Amanero проверенная (в режиме master mode) на другом ЦАПе, 100 % рабочая. Перевел ее в slave mode (поставил только галочку в программе oem tool 117), включил foobar, все настроил, запустил трек, щелкнуло реле, но звука нет! Остановил трек и foobar завис

смотрите внимательно пайку и монтаж элементов по линии I2S, особенно пайку сборки R9 и клоки ну и пайку самого ak4493. 

Цитата: fedy
Думаю, что предыдущее насилование ЦАПа не может привести к такому.

Исключать предыдущие издевательства над ak4493 не стоит, но полагаю хотя бы один канал должен остаться живым...

fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Добрый день! Хочу подключить Amanero без платы адаптера с питанием от usb ( верну на место стабилизатор в Amanero) к плате ЦАП. Подсоединяю 4 провода шины l2S + масса. Какие пины для этого нужно замкнуть на плате ЦАП ?

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года

i2s — rst и control — connect замкнуть на землю

fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Спасибо, вечером попробую

fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Добрый вечер! Проверив все внимательно, нашел не пропаянный контакт 20 чипа AK4493, пропаял все контакты, падение напряжения на резисторах FR13 и FR14 стало — 0 мВ. Но звука по прежнему нет! Еще нашел соплю на аналоговом ключе U12, после её удаления, напряжение на конденсаторах С75 и С76 меняется от 0,5 Вольт до 3,3 Вольт. Даже при замыкании контакта 5 разъема CONFIG на массу, на конденсаторах С75 и С76 все равно есть напряжение от 0,5 до 2 Вольт. По этому поводу есть вопрос, как управляются аналоговые ключи, включаются единицей или нулем на выходах контроллера Y1-on и Y2-on ? 

Пока выпаял оба ключа, напряжение на  С75 и С76 стало 0 Вольт, но звука нет. Прежде чем менять чип AK4493 (к счастью у меня есть ещё один) есть два вопроса:

1. На разных фото видно, что люди при подключении Amanero без платы развязки, замыкают еще на массу контакты 5 и 9 разъема CONFIG. Для проверки работы чипа AK4493, достаточно ли закнуть i2s — rst и control — connect на землю ?

2. Как можно проверить работу чипа AK4493 до выхлопа, что должен показать осциллограф на на выходах 25-26 и 35-36 ?

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: fedy
падение напряжения на резисторах FR13 и FR14 стало — 0 мВ

постарайтесь точнее посмотреть, вообще-то для исправного чипа падение должно быть в районе 2-3мВ

Цитата: fedy
Даже при замыкании контакта 5 разъема CONFIG на массу, на конденсаторах С75 и С76 все равно есть напряжение от 0,5 до 2 Вольт.

Ну это нормально, после отключения клока остаточный заряд 1-0,5 Вольт может оставаться на какое-то время. Но 3.3 там быть точно не должно.

Цитата: fedy
аналоговые ключи, включаются единицей

Да

Цитата: fedy
1. На разных фото видно, что люди при подключении Amanero без платы развязки, замыкают еще на массу контакты 5 и 9 разъема CONFIG.

Ну джампер 5-6 перевод ЦАП-а в с слейв, тут все зависит от конфигурации аманерки, если она мастер, то да, нужен.

9-10 разъема CONFIG — автоопределение DSD  потока, тут ставьте как хочется, 

Цитата: fedy
i2s — rst и control — connect на землю

да, этого достаточно, при этом аманерка должна быть слейвом. Если аманерка мастер добавляете джампер для 5-6 перевода ЦАП-а в слейв

Цитата: fedy
что должен показать осциллограф на на выходах 25-26 и 35-36 ?

звуковой сигнал будет  на выходе, с постоянным смещением 2.5в

fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Добрый вечер! Завтра буду перепаивать чип ЦАПа, т.к. падение напряжения на резисторах FR13 и FR14 — 0 мВ, падение напряжения на резисторах FR11 — 0 мВ, а на FR12 — 3 мВ. Сигнала на выходах 25-26 и 35-36 чипа нет ! Как аккуратнее это сделать? Рядом много деталей? Нужно ли выпаивать соседние электролиты и разъем PROG? И еще остался не понятный вопрос - Аналоговые ключи U11, U12 выпаяны! Включаю ЦАП на одном из конденсаторов С12/С13 ноль вольт, а на том конденсаторе где Y1-on единица — 2,1 Вольта !  Замыкаю контакт 1 — CONTROL на землю, единица переключается на Y2-on и напряжение 2,1 Вольта появляется на другом конденсаторе, так должно быть? Имеет ли значение частота на выходе LRСK Amanero, у меня 96 кГц ?

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года

Электролиты в ближнем радиусе придется выпаять. Далее прикрыть, что подальше фольгой, включая разъем и можно снимать феном. Смд пленка, если применялась, почти 90% на выброс. У Вас смотрю керамика, с ней никаких проблем.

Редактировалось 1 раз, последний: 17:55
fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Доброй ночи ! Перепаял чип ЦАПа и наконец-то я услышал звук! Не обошлось без косяков. Или плата слабая или у меня нет опыта, но контактные площадки 11 и 18 отвалились. 11 вывод чипа не используется, а 18 — спаял вместе с 17 (думаю, аудиофильский бог не обидится). Все работает, звук чистый. Но работает, только если Amanero в режиме master mode (без галочки в прошивки), если прошить Amanero с галочкой  в slave mode, то звука нет и foobar ни чего не воспроизводит. Гальваническую развязку (покупал в Китае) IL717-3. Не знаю куда копать, может быть мне Китайцы подсунули хрень! Можно ли закоротить контакты 6 и 11 IL717-3 ? 

fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Добрый день! Провел эксперимент — Amanero сконфигурировал  в режим master mode (без галочки в прошивки), все работает, звук есть, хотя  при включении разных форматов (44,1 кГц или 96 кГц) генераторы на плате ЦАП переключаются и запаяна IL717-3 ! Отключаю модуль индикации, замыкаю пины 9-10 на разъеме J3 (INDICATOR) на адаптере гальванической развязки и замыкаю на землю пин 5 (CONFIG) на плате ЦАП. Включаю, звука нет ! Проверил - оба генератора на плате ЦАП отключены! Получается, что Amanero работала от генераторов на плате ЦАП? Может такое быть, что Amanero работает от своих генераторов, а ЦАП от своих? Или просто Amanero работала правильно в режиме slave mode, а то что при этом в конфигурации нет галочки, это уже другая проблема ?

Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: fedy
Отключаю модуль индикации, замыкаю пины 9-10 на разъеме J3 (INDICATOR) на адаптере гальванической развязки и замыкаю на землю пин 5 (CONFIG) на плате ЦАП. Включаю, звука нет !

Его и не может быть в этом случае с IL717-3, если ЦАП — слейв, а аманеро — мастер, то надо использовать совершенно другой изолятор, например IL715!

Цитата: fedy
Может такое быть, что Amanero работает от своих генераторов, а ЦАП от своих?

Запросто, так и происходит, если аманерка в слейв не перевелась. Если при разрыве MCLK звук остается, то так оно и есть. Качество звука в этом случае оставляет желать лучшего, периодически могут проскакивать щелчки. 

Цитата: fedy
Или просто Amanero работала правильно в режиме slave mode, а то что при этом в конфигурации нет галочки, это уже другая проблема ?

Ранее установленные галочки не считываются в oemtools, если ранее переводили в слейв, то возможно, что и перевелось.

Чтобы не гадать, делайте аппаратный мод по статье Владимира. До всех переделок вернуть обратно аманеро в мастер в oemtools

https://audiohobby.ru/articles/hardvarnyi-sposob-p...

Редактировалось 2 раза, последний: 10:35
Автор: admin
admin
Сейчас на сайте
Администратор
10 тем
174 сообщения
Рейтинг: 1907
Репутация: 4
На сайте 2 года
Цитата: fedy
если прошить Amanero с галочкой  в slave mode, то звука нет и foobar ни чего не воспроизводит.

а это плохо, не исключено, что канал изолятора мог выйти из строя, с IL717 такого не замечал, а вот канал ADUM-ки может сгореть, когда на его выход подается тактовый сигнал с аманеро. Изолятор имеет однонаправленные каналы, есть вход и есть выход, это следует четко соблюдать. Меняется конфигурация, значит используем другой изолятор!

fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Добрый день! Спасибо, что тратите на меня свое время. Для полной ясности хочу уточнить, как теоретически работает MCLK. Я понимаю так:

1. Если ЦАП в режиме master mode - с генератора на плате ЦАП идут такты MLCK одновременно и на чип ЦАПа и на Amanero. Если Amanero в режиме slave mode и установлена IL717-3, то все работает правильно. Если Amanero тоже в режиме master mode, то работать будет но неправильно со щелчками. Вот тут не понятно, как выбирается нужный генератор ? Может быть у меня проблема с выбором генератора? Пробовал в конфигурации oemtools менять назначение пина 1, не помогает. 

2. Если ЦАП в режиме slave mode — генераторы на плате ЦАПа молчат. Такты MLCK должны поступать на чип ЦАПа с Amanero, которая должна быть в режиме master mode, плюс нужно менять гальваническую развязку ?

Так как у меня есть звук только в первом варианте с Amanero в режиме master mode, то сигнал MCLK  не доходит с генераторов на плате ЦАП до Amanero или он не той частоты. 

По поводу щелков, сегодня вечером послушаю в хорошем качестве. Есть ли способ проверки IL717-3? И еще заметил одну особенность, когда включаешь формат DSD64 и потом ставишь на паузу или на стоп, на экране высвечивается вместо «DSD64» — «PCM 176.4кГц» Это нормально ?

Редактировалось 1 раз, последний: 16:09
fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Добрый вечер! Два вечера слушаю свой новый ЦАП, звук шикарный, не утомляет, сбалансированный, вообщем уровень хорошего промышленного аппарата. Никаких щелчков нет, такое ощущение, что все работает правильно. Завтра сделаю аппаратный мод Amanero по статье Владимира, чтобы окончательно понять причину. 

Пользуясь случаем, хочу выразить огромную благодарность автору проекта за его бесплатную ! работу. Большинство серьезных цапостроителей свои разработки продают за десятки тысяч рублей. Подобные ЦАПы - это апогей самодельного цапостроения, а благодаря подробному описанию, и помощи автора в настройке, такой ЦАП под силу даже простому радиолюбителю.

fedy
Был
Пользователи
1 тема
12 сообщений
Рейтинг: 2
Репутация: 0
На сайте 4 месяца

Добрый вечер! Перевел модуль Amanero хардварным способом в slave режим, включил, звука нет. Проверил всю цепочку MCLK, оказалась не пропаянная резисторная сборка в модуле гальванической развязки! Теперь все работает !

Думаю на этом остановиться. 

Много раз здесь уже про это писали, но хочу еще раз посоветовать Внимательно смотреть качество пайки ОУ стабилизаторов (U13, U23) если один из входов будет в воздухе, то чип ЦАПа может быть «окирпичен» !

Отвечать в темах могут только зарегистрированные пользователи. Вход Регистрация.

Статистика форума
Форумов: 7. Категорий: 11. Тем: 52. Сегодня: 0. Сообщений: 737. Сегодня: 0