audiohobby.ru audiohobby.ru

Обсуждение вопросов по запуску и отладке ЦАП AH-D6

emon
Был сегодня
Пользователи
1 тема
21 сообщение
Рейтинг: 7
Репутация: 0
На сайте 1 год

1) аманеро слейв, цап мастер; подключено через плату-адаптер. при переключении треков щелкают релюшки.

2) аманеро слейв, цап мастер; подключено без платы адаптера, напрямую. при переключении треков релюшки не щелкают. они щелкают только в момент включения всего устройства, и НЕ щелкают при перемотке или смене треков

почему так происходит? я что-то не правильно спаял, или какие-то специфическте настройки?

не верь жене и тормозам
Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год
Цитата: emon

1) аманеро слейв, цап мастер; подключено через плату-адаптер. при переключении треков щелкают релюшки.

2) аманеро слейв, цап мастер; подключено без платы адаптера, напрямую. при переключении треков релюшки не щелкают. они щелкают только в момент включения всего устройства, и НЕ щелкают при перемотке или смене треков

почему так происходит? я что-то не правильно спаял, или какие-то специфическте настройки?

подключали скорее всего без подачи сигнала MUTE на пин RST вот и не щелкали релюхи. А так они и должны щелкать при смене формата / сетки частот / и тд. А вообще у аманерки mute срабатывает избыточно часто.
Если просто при навигации по треку в PCM щелкает — разбирайтесь с плеером, значит вставляет «фрагмент тишины».

foma
Был
Пользователи
1 тема
8 сообщений
Рейтинг: 9
Репутация: 0
На сайте 3 года
Цитата: anton11
Итак, поставил я сегодня силмики 470 мф в референс и в питание аналогового фильтра, в питании фильтра при замене резисторов FR на перемычки — полет нормальный, генерации нет, а вот в питании референса при замене отвязывающих резисторов на перемычки возникла генерация амплитудой 1,5 мВ (смотрел на третей ноге операционника стаба), при установке отвязывающего резистора 0,33 ом генерация пропала

Самое интересное не сказали, как звук поменялся?


anton11
Был
Пользователи
Нет тем
5 сообщений
Рейтинг: 1
Репутация: 0
На сайте 2 года
Цитата: foma
Цитата: anton11
Итак, поставил я сегодня силмики 470 мф в референс и в питание аналогового фильтра, в питании фильтра при замене резисторов FR на перемычки — полет нормальный, генерации нет, а вот в питании референса при замене отвязывающих резисторов на перемычки возникла генерация амплитудой 1,5 мВ (смотрел на третей ноге операционника стаба), при установке отвязывающего резистора 0,33 ом генерация пропала

Самое интересное не сказали, как звук поменялся?

Звук поменялся в лучшую сторону на мой вкус, самая лучшая детальность и самая вкусная середина) 

С шунтирующими конденсаторами панасоник 0,47 мф к ВЧ вообще вопросов нет,

Бас тоже очень неплохой, но самый низ не такой плотный и жирный как у ничикон КЗ, в общем результатом полностью доволен, на этом варианте и остановлюсь.

Dima2t80
Был сегодня
Пользователи
Нет тем
16 сообщений
Рейтинг: 13
Репутация: 0
На сайте 2 года
Цитата: anton11
Цитата: foma
Цитата: anton11
Итак, поставил я сегодня силмики 470 мф в референс и в питание аналогового фильтра, в питании фильтра при замене резисторов FR на перемычки — полет нормальный, генерации нет, а вот в питании референса при замене отвязывающих резисторов на перемычки возникла генерация амплитудой 1,5 мВ (смотрел на третей ноге операционника стаба), при установке отвязывающего резистора 0,33 ом генерация пропала

Самое интересное не сказали, как звук поменялся?

Звук поменялся в лучшую сторону на мой вкус, самая лучшая детальность и самая вкусная середина) 

С шунтирующими конденсаторами панасоник 0,47 мф к ВЧ вообще вопросов нет,

Бас тоже очень неплохой, но самый низ не такой плотный и жирный как у ничикон КЗ, в общем результатом полностью доволен, на этом варианте и остановлюсь.

Схожие ощущения.)))

leonovsp
Был
Пользователи
Нет тем
9 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

Добрый день!

Прошу помочь

Собрал данный аппарат (установил ak4493). Проверил напряжения по описанной процедуре. Все норм. Подключаю через плату адаптер к китайской Amanero без модуля индикации.

Если включаю ЦАП, затем запускаю плеер на компе — реле щелкают, звука нет.

Если сперва включить плеер (в браузере) а потом подключить ЦАП — звук есть и далее можно слушать через любой плеер.

Я в этом деле не достаточно опытен. Подскажите пожалуйста на что обратить внимание? В моем понимании — сигнал приходит на чип, а он почему то не выдает аналоговый сигнал.

HiKKiDimKa
Был вчера
Пользователи
Нет тем
7 сообщений
Рейтинг: 4
Репутация: 0
На сайте 2 года
Цитата: leonovsp

Если включаю ЦАП, затем запускаю плеер на компе — реле щелкают, звука нет.

Если сперва включить плеер (в браузере) а потом подключить ЦАП — звук есть и далее можно слушать через любой плеер.

Настройки вывода звука, какая ОС, прошивки на аманеро\ЦАПе и т.д. — по подробнее бы...

leonovsp
Был
Пользователи
Нет тем
9 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: HiKKiDimKa
Цитата: leonovsp

Настройки вывода звука, какая ОС, прошивки на аманеро\ЦАПе и т.д. — по подробнее бы...

Аманеро компьютером ( установлена винда 10) определяется как надо, изначально была переведена в ведомый режим програмно, на данный момент переведена хардварным способом — результат одинаков.

Формат вывода по умолчанию стоит 16 бит, 48000Гц — или я не так понял о чем реч?

На ЦАПе установлена Атмега88PA, прошивка AH-D6-mk3-ak4493-firmware-v2.1-atmega88-1Mhz. Прошивалась на частоте 1 МГц, верификацию прошла норм.

HiKKiDimKa
Был вчера
Пользователи
Нет тем
7 сообщений
Рейтинг: 4
Репутация: 0
На сайте 2 года
Цитата: leonovsp
или я не так понял о чем реч?

Уже лучше, но также мало данных)

Прошивка есть на аманеро, дисплее и цапе. 

У винды 10й есть список устройств вывода звука, браузер тоже может использовать разные устройства, так же как и плеер. 

Так же у аманеро есть несколько версий драйвера.

Когда пропадает звук в браузере? 

Каким образом слушали плеер? (открыли браузер, включили\выключили музыку где)

И т.д. думаю смысл теперь более понятен.

Очень многое кроется в нюансах...

leonovsp
Был
Пользователи
Нет тем
9 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: HiKKiDimKa
Цитата: leonovsp

Прошивка есть на аманеро, дисплее и цапе. 

У винды 10й есть список устройств вывода звука, браузер тоже может использовать разные устройства, так же как и плеер. 

Так же у аманеро есть несколько версий драйвера.

Когда пропадает звук в браузере? 

На аманеро прошивка CPLD_1080. Драйвер установлен combo384_drivers_w10_1062.

Дисплей не подключаю на данный момент вообще (на нем прошита firmware-m88).

На ЦАП прошивка из статьи AH-D6-mk3-ak4493-firmware-v2.1-atmega88-1Mhz.

При подключении в правом нижнем углу экрана (там где значок динамика) выбираю — проигрывать через аманеро.

Чтобы появился звук, нужно:

1) включить плеер в браузере интернета и включить любой трек, чтобы шел  сигнал, при этом USB кабель подключен к аманеро, а питание цапа выключено (компьютер не видит аманеро и сигнал идет аналогом на штатные колонки). 

2) во время проигрывания трека, включаю питание ЦАП. Компьютер автоматом переводит вывод сигнала на USB Amanero, реле ЦАП щелкают, еще проходит секунда и появляется звук (через ЦАП то есть). Дальше можно переключать плееры, треки и т.д. звук будет до того момента пока ЦАП работает. 

Если же сперва включить ЦАП (при этом компьютер автоматом переведет вывод сигнала на Аманеро) а потом включать любые плееры, браузеры и т.д. — реле щелкают но звука нет.

Т.е. если ЦАП включен раньше плеера то звука нет.

Питание организовано от модуля АН-PW5. 

Не могу понять от куда начать поиски? Может такое быть из-за винды?

zaycev
Был вчера
Модераторы
1 тема
11 сообщений
Рейтинг: 24
Репутация: 0
На сайте 1 год

А Вы попробуйте локализовать проблему, попробуйте на другом ПК или вообще к планшету / телефону подключить, если поддерживает OTG. Или вообще можно запуститься с liveCD с линуксом, сразу станет понятнее куда копать.

HiKKiDimKa
Был вчера
Пользователи
Нет тем
7 сообщений
Рейтинг: 4
Репутация: 0
На сайте 2 года
Цитата: leonovsp
компьютер не видит аманеро
Компьютер автоматом переводит вывод сигнала на USB Amanero

Это как понимать? зачем выключать питание, если цап сам включится при подаче звукового сигнала через аманеро.

Браузер нужно запускать только после инициализации всех звуковоспроизводящих устройств, вывод будет осуществляться через устройство по умолчанию.

Да, на этой прошивке есть небольшая задержка перед запуском цап для звуковоспроизведения.

При той ситуации, когда звук не воспроизводится, а реле отщелкнулись в диспетчере устройств звук через что выводится (отображается индикатор уровня воспроизведения)?

Сначала нужно определить через что посылается звук (может у вас в мониторе есть свой цап), не отключается ли аманерка по какой-либо причине в винде.

leonovsp
Был
Пользователи
Нет тем
9 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: zaycev

А Вы попробуйте локализовать проблему, попробуйте на другом ПК или вообще к планшету / телефону подключить, если поддерживает OTG. Или вообще можно запуститься с liveCD с линуксом, сразу станет понятнее куда копать.

С линукса не смогу, а вот с телефона попробую, надо переходник только раздобыть

leonovsp
Был
Пользователи
Нет тем
9 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: HiKKiDimKa
Цитата: leonovsp
компьютер не видит аманеро 

Это как понимать? зачем выключать питание, если цап сам включится при подаче звукового сигнала через аманеро.

Цап выключен из розетки, вот комп его и не видит. Звук идет через штатные колонки (аналоговый выход). В этот мент включаю ЦАП в розетку (дисплея нет, он включается автоматом), комп видит включившуюся аманеро и переводит вывод с аналогово сигнал на USB Amanero. 

«Браузер нужно запускать только после инициализации всех звуковоспроизводящих устройств, вывод будет осуществляться через устройство по умолчанию.» — в таком случае он выводит сигнал через аманеро (по умолчанию) но звука нет.

«При той ситуации, когда звук не воспроизводится, а реле отщелкнулись в диспетчере устройств звук через что выводится (отображается индикатор уровня воспроизведения)?» -  USB Amanero.

zaycev
Был вчера
Модераторы
1 тема
11 сообщений
Рейтинг: 24
Репутация: 0
На сайте 1 год
Цитата: leonovsp
С линукса не смогу,

Почему? если нет привода, так на флешку образ закатайте, Rufus в помощь, если совсем опыта нет, то убунту студио попробйте. Я вот себе Daphile образ сделал и теперь частенько пользуюсь, звучание намного лучше винды!

leonovsp
Был
Пользователи
Нет тем
9 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: zaycev
убунту студио попробйте

Опыта нет. Но видимо придется попробовать )

Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год

Треки с частой дискретизации кратной 48кГц играет?

leonovsp
Был
Пользователи
Нет тем
9 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: admin

Треки с частой дискретизации кратной 48кГц играет?

В настройках винды выбирал разные форматы по умолчанию, в том счисле и 48, 44.1, 32 кГц — играет все (если конечно об этих настройках речь). 

Как по ощущениям вся проблема момент первого запуска. Вроде комп все видит, включаю плэй, реле щелкнули и… тишина.

HiKKiDimKa
Был вчера
Пользователи
Нет тем
7 сообщений
Рейтинг: 4
Репутация: 0
На сайте 2 года
Цитата: leonovsp
Цитата: admin

Треки с частой дискретизации кратной 48кГц играет?

и… тишина.

С конденсаторами не переборщили?

leonovsp
Был
Пользователи
Нет тем
9 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: HiKKiDimKa
Цитата: leonovsp
Цитата: admin

Треки с частой дискретизации кратной 48кГц играет?

и… тишина.

С конденсаторами не переборщили?

В транспорте? Электролиты проверял — все по рекомендациям без фанатизма. Керамику особо не проверишь

Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год

У меня пока объяснения на аппаратном уровне со стороны ЦАП данному поведению нет, пробуйте с другой системой или на другом устройстве, про рекомендации Романа (ака zaycev).

Может еще какие-то профили энергосбережения в винде включены, попробуйте сменить порт USB, как-то один из форумчан ловил проблемы с USB 3.0 / 3.1 на своем ПК (но это были просто отвалы устройства).

foma
Был
Пользователи
1 тема
8 сообщений
Рейтинг: 9
Репутация: 0
На сайте 3 года
один из форумчан ловил проблемы с USB 3.0 / 3.1 на своем ПК (но это были просто отвалы устройства).

 о это про меня, цап чудил пока не переключил на USB2.0 порт

leonovsp
Был
Пользователи
Нет тем
9 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: admin

 пробуйте с другой системой или на другом устройстве, про рекомендации Романа (ака zaycev).

С планшета и телефона воспроизведения нет вообще — тишина. 

Попробую заметить атмегу (брал с ЧиПа Атмегу 88AU).

Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год
Цитата: leonovsp
Цитата: admin

 пробуйте с другой системой или на другом устройстве, про рекомендации Романа (ака zaycev).

С планшета и телефона воспроизведения нет вообще — тишина. 

Попробую заметить атмегу (брал с ЧиПа Атмегу 88AU).

— точно вывод идет через ЦАП? устройство планшет / телефон вообще видит аманеро?

поставьте Neutron player и в его настройках выберете вывод на аманеро -(сombo384)

Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год

Некоторые устройства не выводят на USB вообще тк нет поддержки OTG, а в некоторых прикручен мониторинг нагрузки при USB-хост подключении.

Если аманеро питается от внешнего питания, то на ее usb +5 надо повесить  небольшой нагрузочный резистор 1-5Ком (я ставил вместо входной емкости). 

Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год

Перенес сюда кусок ветки из комментариев

emon

12.10.2020 17:58 

emon

корпус для ЦАПа. рисовал сам(SolidWorks). отдал на производство, через пару дней будет тестовый образец. могу поделиться чертежами. 1мм сталь, порошковая покраска.

вот с этого перерисовывал

zaycev

12.10.2020 20:13

zaycev

Интересно, cколько по цене получается? А вообще, круто, для меня корпуса это вечная головная боль.

emon

12.10.2020 20:21

emon

аналогичная головная боль.

зависит от завода, на котором это будет делаться.

на одном мне озвучили цену в 50 баксов, на втором 15 баксов. заказал за 15(метал их, лазерная резка, гибка, порошковая покраска). Делаю у них корпуса к ламповым усилкам — качество хорошее получается.

через пару дней поеду за заказом, сфоткаю что получилось.

по размерам 180х180х50. на передней панели только 1мм отверстие для светодиода(нравится мне как в маках делают)

zaycev

12.10.2020 20:58

zaycev

Спасибо. Интересно, что получится.

caleb

13.10.2020 12:47 (отредактировано)

caleb

Сильно интересно что получится, корпуса похоже извечная головная боль.

Что это за предприятие такое, согласившееся за 15 сделать корпус.

Мне пока только вот это попалось.

blagstore.ru/ Но опять же китайцы, этим все сказано.

emon

20.10.2020 14:53

emon

вот что получилось

caleb

20.10.2020 15:22

caleb

Отверстия могли бы и по качественнее вырубить.

emon

20.10.2020 15:36

emon

они не в ту сторону выгнули верхнюю крышку просто. внутри они красивые получились :)

caleb

20.10.2020 15:39 (отредактировано)

caleb

Как обычно, ни хрена не могут сразу без косяков сделать. И как заказывать после такого !? Или надеются что не заметят .

Что хоть за герои заказ исполняли?

emon

20.10.2020 15:45

emon

я не возмущаюсь, ибо на одном заводе озвучили цену в 70 баксов, а на этом в 15. поэтому считаю что норм. :)

emon
Был сегодня
Пользователи
1 тема
21 сообщение
Рейтинг: 7
Репутация: 0
На сайте 1 год

чипы пропали.

у кого-то может есть какие новости?

или догадки

появятся чипы в продаже или нет?

не, ну они конечно есть еще, но например 4497 по 180 баксов просят на алике, 4490 от 60

не верь жене и тормозам
Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год
IgorZ67
Был
Пользователи
Нет тем
2 сообщения
Рейтинг: 0
Репутация: 0
На сайте 1 год

Собрал ЦАП, напряжения на стабах в норме. Два программатора USBAsp купленных в разных местах не видят атмегу 88-20aur, брал на дигикей. Ни в цапе ни в блоке индикации, пишет необходимо обновление, что делать?

emon
Был сегодня
Пользователи
1 тема
21 сообщение
Рейтинг: 7
Репутация: 0
На сайте 1 год
Цитата: IgorZ67

Собрал ЦАП, напряжения на стабах в норме. Два программатора USBAsp купленных в разных местах не видят атмегу 88-20aur, брал на дигикей. Ни в цапе ни в блоке индикации, пишет необходимо обновление, что делать?

кто, кто пишет что надо обновить?

если софтина — обновите ее.

будет круто, если пришлете скриншоты.

не верь жене и тормозам
caleb
Был вчера
Знатоки
Нет тем
51 сообщение
Рейтинг: 50
Репутация: 0
На сайте 2 года

Как чипы  пропали!? сняли с продажи что ли? странно, за ними и так очередь не стояла .

aliexpress.ru/item/4000482431604.html?spm=a2g0o.productlist.0.0.548c6c21LCdbU9&algo_pvid=d861f170-a1bb-4208-9599-cf8d413a09e8&algo_expid=d861f170-a1bb-4208-9599-cf8d413a09e8-31&btsid=0b8b158f16091760776561254e1885&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_&sku_id=10000002002658151  вроде вполне адекватная цена

caleb
Был вчера
Знатоки
Нет тем
51 сообщение
Рейтинг: 50
Репутация: 0
На сайте 2 года

https://www.ebay.com/itm/AKM-high-end-DAC-chip-AK4...

Над этим маркетинговым ходом ржал долго ........

А вот с какого хрена так 4490тые подорожали совсем не понятно, не так давно, полгода назад по 200р покупал, задрали  в 3 с лишним раза цену.

Редактировалось 1 раз, последний: 20:33
emon
Был сегодня
Пользователи
1 тема
21 сообщение
Рейтинг: 7
Репутация: 0
На сайте 1 год
Цитата: caleb

Как чипы  пропали!? сняли с продажи что ли? странно, за ними и так очередь не стояла .

aliexpress.ru/item/4000482431604.html?spm=a2g0o.productlist.0.0.548c6c21LCdbU9&algo_pvid=d861f170-a1bb-4208-9599-cf8d413a09e8&algo_expid=d861f170-a1bb-4208-9599-cf8d413a09e8-31&btsid=0b8b158f16091760776561254e1885&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_&sku_id=10000002002658151  вроде вполне адекватная цена

это обьявление есть. попробуйте купить, или спросить продавца, есть ли в наличии. нету их по факту. вообще.

не верь жене и тормозам
caleb
Был вчера
Знатоки
Нет тем
51 сообщение
Рейтинг: 50
Репутация: 0
На сайте 2 года

А нафига тогда объявление держать на сайте !? спецом попробую купить. 

emon
Был сегодня
Пользователи
1 тема
21 сообщение
Рейтинг: 7
Репутация: 0
На сайте 1 год
Цитата: caleb

А нафига тогда объявление держать на сайте !? спецом попробую купить. 

обьявления остаются на сайте, потому чтоб не терять позицию в поиске и ссылку, которая как правило используется для раскрутки. новой обьявление потом будет с другой ссылкой.

не верь жене и тормозам
IgorZ67
Был
Пользователи
Нет тем
2 сообщения
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: emon
Цитата: IgorZ67

Собрал ЦАП, напряжения на стабах в норме. Два программатора USBAsp купленных в разных местах не видят атмегу 88-20aur, брал на дигикей. Ни в цапе ни в блоке индикации, пишет необходимо обновление, что делать?

кто, кто пишет что надо обновить?

если софтина — обновите ее.

будет круто, если пришлете скриншоты.

avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.
avrdude.exe: error: program enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

Два программатора, два контроллера- результат один

emon
Был сегодня
Пользователи
1 тема
21 сообщение
Рейтинг: 7
Репутация: 0
На сайте 1 год
Цитата: IgorZ67
Цитата: emon
Цитата: IgorZ67

Собрал ЦАП, напряжения на стабах в норме. Два программатора USBAsp купленных в разных местах не видят атмегу 88-20aur, брал на дигикей. Ни в цапе ни в блоке индикации, пишет необходимо обновление, что делать?

кто, кто пишет что надо обновить?

если софтина — обновите ее.

будет круто, если пришлете скриншоты.

avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.avrdude.exe: error: program enable: target doesn't answer. 1 avrdude.exe: initialization failed, rc=-1Double check connections and try again, or use -F to overridethis check.

Два программатора, два контроллера- результат один

проверьте питание, приходит ли с программатора
выставьте перемычку на малую скорость
надо детальнее логи смотреть, программатор просто не видит чип. обновлять там ничего не нужно.
прикрепите если можно фото как Вы его подключаете
ну и пайку проверить

я «игрался» в конфигах с сигнатурами, пока программатор не «увидел» атмегу

Редактировалось 3 раза, последний: 21:15
не верь жене и тормозам
GoRR
Был
Пользователи
Нет тем
8 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

Интересная история у меня получилась.
Еще год тому собрал данный цап. Не без приключений, но все же запустил, подружил с BeagleBone и он сейчас играет и радует. Но не давало покоя тот факт, что не хотел он нормально воспроизводить DSD. Максимум чего добился, это воспроизведения DSD64. В конечном счете заполучил осцилограф и решил посмотреть что там у меня творится. А там жесть — осциляторы NDK на 45 и 49 Мгц, купленные у jlsound выдавали по 1 Мгц!!!
Ок, померял другие свои цапы, где стоят китайские на 22 Мгц — там все норм, частота соответствует.

На самих осциляторах маркировка правильная. Получается либо мне фуфло продали, либо я что-то напартачил при сборке цапа. Кто-сталкивался, пожалуйста, дайте наводку куда копать.

Редактировалось 1 раз, последний: 15:34
Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год
Цитата: GoRR
А там жесть — осциляторы NDK на 45 и 49 Мгц, купленные у jlsound выдавали по 1 Мгц!!!

Точно измерения верны? Пока больше склоняюсь к ошибке измерений.

Сам у болгарина покупал клоки на 45 и 49, никаких проблем, вот сейчас прямо с ними цап стоит и работает. Замеры делал никаких проблем.

Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год

Полоса пропускания какая у осциллографа, что за прибор ?

GoRR
Был
Пользователи
Нет тем
8 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год
Цитата: admin

Полоса пропускания какая у осциллографа, что за прибор ?

Вполне возможно что ошибка измерений, так как у прибора 20Мгц полоса пропускания.
Прибор такой — https://aliexpress.ru/item/32352939179.html

Помню ранее была у меня проблема со скоростью воспроизведения (медленно играло), пришлось вручную в файле настроек Volumio указывать частоту осциляторов. После этого скорость приходила в норму.  На основании этого факта делаю вывод что таки частоты там верные, иначе бы ничего не играло при таких настройках.

Редактировалось 1 раз, последний: 22:51
GoRR
Был
Пользователи
Нет тем
8 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

Завтра попробую потыкать осцилографом, посмотреть идет ли сигнал при воспроизведении DSD. Если на входных пинах сигнал будет, то следующие точки для замера на входе в AK4493?
И не знаю на что смотреть и нужно ли запускать на воспроизведение звук определенной частоты?
Хочется все-таки докопаться до сути проблемы и хотя бы вывести DSD128, много хороших записей уже в этом формате накопилось.

Редактировалось 1 раз, последний: 22:53
Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год
Цитата: GoRR
На основании этого факта делаю вывод что таки частоты там верные, иначе бы ничего не играло при таких настройках. 

Скорее всего врет осциллограф, полосы 20Мгц не хватает. 

Клоки на 45.158MHz / 49.152MHz как удалось проверить не очень походят для ak4490/4493, оно работает, но искажения получаются немного выше, чем со штатными 22/24M. 

У себя в экспериментах в итоге поставил делитель частоты на 2 перед самым ЦАП при клоках 45.158MHz / 49.152MHz. Со сборкой прошивки Павла Погодина DSD256 отлично играло, думаю основная проблема в софте и конфигах драйвера.

Сборку под BBB и переходник/реклокер использовал от Павла - https://puredsd.ru/. Слушал через HQplayer. Отмечу, что достижимое качество звука при воспроизведении через BBB получилось выше на мой слух, чем при использовании amanero и других usb свистков. 

GoRR
Был
Пользователи
Нет тем
8 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

Сейчас на прошивке от Павла и слушаю, втянулся в новый виток ковыряния, поэтому и про DSD поднял вопрос. Не хотелось, но видимо прийдется клоки на 22/24 заказывать и менять.

GoRR
Был
Пользователи
Нет тем
8 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

Проблему с софтом исключаю, при том же источнике (ВВВ с переходником) китайский цап на AK4495 воспроизводит DSD128 без проблем, даже DSD256 с редкими заиканиями тянет. Тут скорее всего железная проблема. Год тому я пробовал цап и в режиме слейв и в режиме мастер — результат DSD64 максимум. Сейчас снова попробую провести те же эксперименты, может что упустил. Заодно нарисую себе схемы по конфигурации джамперов и подключения, а то каждый раз все заново вспоминать надо. Сюда выложу, может кому и пригодится. Также думаю стоит под лупой изучить номиналы резисторов в цифровой части.

Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год
Цитата: GoRR

Проблему с софтом исключаю, при том же источнике (ВВВ с переходником) китайский цап на AK4495 воспроизводит DSD128 без проблем, даже DSD256 с редкими заиканиями тянет. Тут скорее всего железная проблема. Год тому я пробовал цап и в режиме слейв и в режиме мастер — результат DSD64 максимум. Сейчас снова попробую провести те же эксперименты, может что упустил. Заодно нарисую себе схемы по конфигурации джамперов и подключения, а то каждый раз все заново вспоминать надо. Сюда выложу, может кому и пригодится. Также думаю стоит под лупой изучить номиналы резисторов в цифровой части.

Какова настройка в CONFIG? пробовали ставить джампер на «Контакт 7» и играться настройками "Control : «Контакты 5, 9»

Config: «Контакт 7 — режим определения частоты дискретизации. Если уровень «1» (отсутствие джампера), то частота мастер клока и частота дискретизации определяются автоматически (AK4493 — Auto Setting Mode, ACKS bit = “1”). Если «0» (присутствие джампера), то частота MCLK определяется автоматически, а частота дискретизации передается с транспорта, задается пинами управления 5 и 9.»

Control : «Контакты 5, 9 — На них выдаются транспортом уровни в зависимости от текущей частоты дискретизации:

Частота дискретизацииPin 9Pin 5
44.1кГц/48.0кГц/DSD6400
88.2кГц/96.0кГц/DSD12801
176.4кГц/192.0кГц/DSD25610
352.8кГц/384.0кГц/DSD51211


Если в CONFIG выбрана опция автоматического определения частоты дискретизации, значения контактов 5 и 9 игнорируются (в режиме PCM для AK4493 выставляется ACKS бит = “1” см. раздел CONFIG, а при воспроизведении DSD потока, выбирается сразу DSD256, в этом режиме DSD512 будет не доступен).»


Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год

Также интересно какова использовалась версия прошивки ЦАП?

GoRR
Был
Пользователи
Нет тем
8 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

В CONFIG не стоят джамперы совсем, в CONTROL задействованы пины 1, 3 и 5. На них идет управляющий сигнал с переходника BBB.

Ранее (год тому) пробовал проигрывать DSD и с джампером в CONFIG, с ручным выставлением частот на CONTROL — на сколько помню при разных вариациях джамперов звука либо вообще небыло, либо играл только DSD64.
Также пробовал проигрывание при работе цапа в режиме Слейв, та же история.


Версию прошивки не скажу, так как мне прошивал форумчанин, у меня програматора нет. Но это было в сентябре-октябре 2019 года, тоесть она явно не свежая.

Редактировалось 3 раза, последний: 20:27
Автор: admin
admin
Был сегодня
Администратор
6 тем
101 сообщение
Рейтинг: 1494
Репутация: 4
На сайте 1 год
Цитата: GoRR
Версию прошивки не скажу, так как мне прошивал форумчанин, у меня програматора нет. Но это было в сентябре-октябре 2019 года, тоесть она явно не свежая.

лучше бы было обновить, в новой я делал мелкие правки и добавлял еще дополнительно команды сброса для ak449х при изменении состояния CONTROL, особенно актуально для транспорта, который не дает сигнала сброса (или не все отслеживает и не всегда выдает сброс).

GoRR
Был
Пользователи
Нет тем
8 сообщений
Рейтинг: 0
Репутация: 0
На сайте 1 год

Пока не понял почему раньше не играло, но сейчас заиграл DSD256 при джамперах 7 и 9 на CONFIG. 

Ура товарищи!

Отвечать в темах могут только зарегистрированные пользователи. Вход Регистрация.

Сейчас онлайн
Статистика форума
Форумов: 7. Категорий: 11. Тем: 32. Сегодня: 0. Сообщений: 484. Сегодня: 0